Cant play pixel worlds

unity crash

Have you tried to see if the process is open in the taskmanager? Or maybe trying to uninstall and install teh game back again, it’s not a big game, so it shouldn’t take too much time to try that

This happens sometimes on pc

In personally i haven’t had this kind of issue never with the game, do you play from steam or microsoft store?

On steam usually

Had that once, you can fix it by either killing the process on task manager or restarting your device.

i play on steam version

uninstalled and installed again its the same again

what do you mean by killing process

cant install on microsoft store either

try to “kill” the process by going to the task manager, finding the pixel worlds.exe and right clicking on it, and click “end process”

didnt work out…asxz vvcnb

I think the microsft store version of the game doesn’t really work in general and microsoft has pretty much abandoned it

Have you tried to fix the files if smth is corrupted on there?
Go to steam and open your Steam Library, then right-click the game, and then click Properties.
Click the Local Files tab, after that click Verify Integrity of Game Files to perform the repair installation.

this is pretty much true, the steam version is much more stable

this problem is caused by sawcon

duckles, i wont fall to that again.

That’s because it’s actually caused by gulpin.

ok guys thanks its fixed after the hotfix update

Glad you got it working!