Fishing is broken for me

Even when using an amulet, nothing works. The lure is constantly stolen.
I thought the maintenance would fix it, but nothing happened. 50 baits in a row, and all of them were stolen. I tried using another rod, switching sets, nothing. Other people have the issue, but it seems the majority don’t. I was showing people the issue on the stream in the discord. Jake joined in for a couple of seconds, but Jake’s logic is that the majority aren’t having a problem then it isn’t worth it for them to fix it. This logic applies to the other bugs I’ve been reporting for over a year.

does fishing got nerfed or you got bugged on your gears? cause mine seems fine.

I said quite clearly, the bait is stolen 100% of the time, even with the amulet that literally states disables stolen lures — I don’t get why this is the first reply people always have when I mention this bug.

I hope it will be fix @Neoslayer , Devs will listen to us just wait for little bit .
cheers bro!


Maintenance should have fixed this, taking another look.


Tanks :confused:
I hope I won’t need to wait a month or two to fish…
I think I’m going to try opening the game on mobile instead of steam version and seeing if it works there

Potential Pog Moment.jpeg

That’s why i sold my fishing set.

Problem solved :sunglasses:

Just tried fishing on mobile and it worked -
However there’s a catch. It only worked with the basic bamboo. The superior titanium rod won’t even get any strikes anymore, no matter how long I wait, no matter which bait, no matter the area. Something is clearly wrong…
Maybe pressing random world is tied to this?
However, I encountered someone with my previous issue.

Tried on steam version once more, and it’s getting lost every time again.
The bamboo rod also loses bait. So the bug seems to only be tied to Steam version and Windows version as far as I’m aware
It works on mobile. I just had bad luck.

idk how common the issue is, but i just fished 15 lures on steam and no lost lures.

edit: if relevant, i am wearing amulet, pf suit, snufnomad hat, whistle and im using a bamboo (superior) rod.

Then I guess the only thing I could try doing is restarting my PC and reinstalling the game

It has to do with the system clock. Your device time differs too much from the server’s. I’ll try to look for a fix that can be done by maintenance.

Oh that’s interesting; thanks for telling me. I always noticed on discord, it’d show messages saying “Tomorrow at 12:00” 2 minutes behind, but I don’t really know how to set it to the normal time

Doing another maintenance that will hopefully fix this.

It’s fixed! Thanks :slight_smile:
I still think I wanna figure out how I can fix my clock though lol