Game keeps crashing when buying gems from the Gemstone Buyer/Fish Barrel

Title says it. It keeps happening to me every single time ever since the new Xmas update came out but hours before the update, the game was working just fine. Buying gems was not a problem and I don’t get disconnected at all.

I also found out that I wasn’t the only one experiencing this. There were a few people in-game talking about it and someone has also metioned this in the discord server.

Kindly please fix this, devs. Thank you!


what device are you using to play the game?

I use my android phone. But like I said, it was normal before until the update came out.

Could you tell me more in detail: What items are you selling and where? In the game you cannot sell gems.

Oh, my bad. I meant BUYING gems for gemstones and fishes in the Gemstone Buyer/ Fish Barrel. I’m sorry :sweat_smile:

We’ve tried to replicate this issue but haven’t been able to break it. Do you have screenshots of these situations? Does it ever work? What if you store some of the items away and only try to sell some of them?

So you are selling your gemstones and fish to the vendors apparently :smiley:

Yes, I am. It only happened to me when I sold my gemstones but someone mentioned it on discord that the same thing has happened to them when they sold their fishes, and I thought I was the only one.

I’ve tried mining again, the bug has apparently been gone. Don’t know if it was just because I tried selling my gemstones immediately once the update has come out. But I’ll try to inform you guys once I’ve experienced it again. I will grind some gemstones to sell for now so I could send some proofs about the bug.

Were you selling the same items as before? Did you open the menu multiple times?

The bug is definitely happening since we can see some shady crash logs related to those menus.

Uh no, I’ve sold different types.

Also, I just remembered that there is also another bug with buying gems from the gemstone buyer, for an example I was selling my topaz huge but it kept saying tiny sapphire/emerald (I don’t remember clearly, sorry) because it is right next to it, and even though I kept selecting the topaz it still kept saying that it was a different gemstone.